What’s Vulnerable › Vulnerabilities
CVE-2025-49587: XWiki does not require right warnings for notification displayer objects
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-357
Description
XWiki is an open-source wiki software platform. When a user without script right creates a document with an XWiki.Notifications.Code.NotificationDisplayerClass object, and later an admin edits and saves that document, the possibly malicious content of that object is output as raw HTML, allowing XSS attacks. While the notification displayer executes Velocity, the existing generic analyzer already warns admins before editing Velocity code. Note that warnings before editing documents with dangerous properties have only been introduced in XWiki 15.9, before that version, this was a known issue and the advice was simply to be careful. This vulnerability has been patched in XWiki 15.10.16, 16.4.7, and 16.10.2 by adding a required rights analyzer that warns the admin before editing about the possibly malicious code.
Affected products
- xwiki-platform: from 15.9 before 15.10.16; from 16.0.0 before 16.4.7; from 16.5.0 before 16.10.2 — fixed in 15.10.16, 16.10.2, 16.4.7
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.16, 16.10.2, 16.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/55c5d568c4dc4619f37397d00d14dcdeab9c252d
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-j7p2-87q3-44w7
- https://jira.xwiki.org/browse/XWIKI-22470
Get alerted when CVE-2025-49587 or the next vulnerability affects your stack