What’s Vulnerable › Vulnerabilities
CVE-2025-49596: MCP Inspector proxy server lacks authentication between the Inspector client and proxy
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 44.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-306
Description
The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Affected products
- modelcontextprotocol inspector: before 0.14.1
References
- https://github.com/modelcontextprotocol/inspector/commit/50df0e1ec488f3983740b4d28d2a968f12eb8979
- https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-7f8r-222p-6f5g
- https://thenewstack.io/mcp-vulnerability-exposes-the-ai-untrusted-code-crisis
- https://www.oligo.security/blog/critical-rce-vulnerability-in-anthropic-mcp-inspector-cve-2025-49596
Get alerted when CVE-2025-49596 or the next vulnerability affects your stack