What’s Vulnerable › Vulnerabilities

CVE-2025-49630: Apache HTTP Server: mod_proxy_http2 denial of service

Description

In certain proxy configurations, a denial of service attack against Apache HTTP Server versions 2.4.26 through to 2.4.63 can be triggered by untrusted clients causing an assertion in mod_proxy_http2. Configurations affected are a reverse proxy is configured for an HTTP/2 backend, with ProxyPreserveHost set to "on".

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.64. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-49630 or the next vulnerability affects your stack