What’s Vulnerable › Vulnerabilities
CVE-2025-4968: WPBakery Page Builder <= 8.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Page Builder Elements
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPBakery Page Builder for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple Page Builder elements (Copyright Element, Hover Box, Separator With Text, FAQ, Single Image, Custom Header, Button, Call To Action, Progress Bar, Pie Chart, Round Chart, and Line Chart) in all versions up to, and including, 8.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPBakery Page Builder: before 8.5 — fixed in 8.5
How to fix
Upgrade to a fixed version: WPBakery Page Builder 8.5. Check the vendor advisory for mitigations.
References
- https://kb.wpbakery.com/docs/preface/release-notes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10945855-675a-4a85-8bb2-84bc40c1b826?source=cve
Get alerted when CVE-2025-4968 or the next vulnerability affects your stack