What’s Vulnerable › Vulnerabilities
CVE-2025-49717: Microsoft SQL Server Remote Code Execution Vulnerability
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based buffer overflow in SQL Server allows an authorized attacker to execute code over a network.
Affected products
- Microsoft Sql Server 2019: from 15.0.2000.5 before 15.0.2135.5; from 15.0.4003.23 before 15.0.4435.7 — fixed in 15.0.2135.5, 15.0.4435.7
- Microsoft Sql Server 2022: from 16.0.1000.6 before 16.0.1140.6; from 16.0.4003.1 before 16.0.4200.1 — fixed in 16.0.1140.6, 16.0.4200.1
- Microsoft SQL Server 2019 (CU 32): from 15.0.0.0 before 15.0.4435.7 — fixed in 15.0.4435.7
- Microsoft SQL Server 2019 (GDR): from 15.0.0 before 15.0.2135.5 — fixed in 15.0.2135.5
- Microsoft SQL Server 2022 (CU 19): from 16.0.0.0 before 16.0.4200.1 — fixed in 16.0.4200.1
- Microsoft SQL Server 2022 (GDR): from 16.0.0 before 16.0.1140.6 — fixed in 16.0.1140.6
How to fix
Upgrade to a fixed version: Microsoft Sql Server 2019 15.0.2135.5, 15.0.4435.7; Microsoft Sql Server 2022 16.0.1140.6, 16.0.4200.1; Microsoft SQL Server 2019 (CU 32) 15.0.4435.7; Microsoft SQL Server 2019 (GDR) 15.0.2135.5; Microsoft SQL Server 2022 (CU 19) 16.0.4200.1; Microsoft SQL Server 2022 (GDR) 16.0.1140.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-49717 or the next vulnerability affects your stack