What’s Vulnerable › Vulnerabilities
CVE-2025-4972: Incorrect Authorization in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue has been discovered in GitLab EE affecting all versions from 18.0 before 18.0.4 and 18.1 before 18.1.2 that could have allowed authenticated users with invitation privileges to bypass group-level user invitation restrictions by manipulating group invitation functionality.
Affected products
- GitLab: from 18.0.0 before 18.0.4; from 18.1.0 before 18.1.2 — fixed in 18.0.4, 18.1.2
How to fix
Upgrade to a fixed version: GitLab 18.0.4, 18.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4972 or the next vulnerability affects your stack