What’s Vulnerable › Vulnerabilities
CVE-2025-4973: Workreap <= 3.3.1 - Authentication Bypass via 'workreap_verify_user_account'
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-288
Description
The Workreap plugin for WordPress, used by the Workreap - Freelance Marketplace WordPress Theme, is vulnerable to authentication bypass in all versions up to, and including, 3.3.1. This is due to the plugin not properly verifying a user's identity prior to logging them in when verifying an account with an email address. This makes it possible for unauthenticated attackers to log in as registered users, including administrators, if they know user's email address. This is only exploitable fi the user's confirmation_key has not already been set by the plugin.
Affected products
- Workreap: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: Workreap 3.3.2. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/workreap-freelance-marketplace-wordpress-theme/23712454#item-description__release-3-3-2-23-may-2025
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8e7693a3-642a-4eff-902c-d29a3c12deb0?source=cve
Get alerted when CVE-2025-4973 or the next vulnerability affects your stack