What’s Vulnerable › Vulnerabilities

CVE-2025-4976: Exposure of Sensitive Information Due to Incompatible Policies in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions from 17.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that, under certain circumstances, could have allowed an attacker to access internal notes in GitLab Duo responses.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.0.5, 18.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4976 or the next vulnerability affects your stack