What’s Vulnerable › Vulnerabilities
CVE-2025-49763: Apache Traffic Server: Remote DoS via memory exhaustion in ESI Plugin
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-19 · updated 2026-06-17
- Weakness: CWE-400
Description
ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.
Affected products
- Apache Software Foundation Apache Traffic Server: from 9.0.0 before 9.2.11; from 10.0.0 before 10.0.6 — fixed in 10.0.6, 9.2.11
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.0.6, 9.2.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-49763 or the next vulnerability affects your stack