What’s Vulnerable › Vulnerabilities
CVE-2025-4979: Insufficient Granularity of Access Control in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-1220
Description
An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. An attacker may be able to reveal masked or hidden CI variables (that they did not author) in the WebUI, by simply creating their own variable and observing the HTTP response.
Affected products
- GitLab: before 17.10.7; from 17.11.0 before 17.11.3; 18.0.0 — fixed in 17.10.7, 17.11.3
How to fix
Upgrade to a fixed version: GitLab 17.10.7, 17.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4979 or the next vulnerability affects your stack