What’s Vulnerable › Vulnerabilities
CVE-2025-49826: Next.js DoS vulnerability via cache poisoning
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-03 · updated 2026-06-17
- Weakness: CWE-444
Description
Next.js is a React framework for building full-stack web applications. From versions 15.0.4-canary.51 to before 15.1.8, a cache poisoning bug leading to a Denial of Service (DoS) condition was found in Next.js. This issue does not impact customers hosted on Vercel. Under certain conditions, this issue may allow a HTTP 204 response to be cached for static pages, leading to the 204 response being served to all users attempting to access the page. This issue has been addressed in version 15.1.8.
Affected products
- Next.js: from 15.0.4 (excl.) before 15.1.8; 15.0.4-canary51, 15.0.4-canary52 — fixed in 15.1.8
How to fix
Upgrade to a fixed version: Next.js 15.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/a15b974ed707d63ad4da5b74c1441f5b7b120e93
- https://github.com/vercel/next.js/releases/tag/v15.1.8
- https://github.com/vercel/next.js/security/advisories/GHSA-67rr-84xm-4c7r
- https://vercel.com/changelog/cve-2025-49826
Get alerted when CVE-2025-49826 or the next vulnerability affects your stack