What’s Vulnerable › Vulnerabilities
CVE-2025-49844: Redis Lua Use-After-Free may lead to remote code execution
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 82.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-03 · updated 2026-10-19
- Weakness: CWE-416
Description
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate the garbage collector, trigger a use-after-free and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.
Affected products
- valkey-io valkey: before 7.2.11; from 8.0.0 before 8.0.6; from 8.1.0 before 8.1.4 — fixed in 7.2.11, 8.0.6, 8.1.4
- Redis: before 6.2.20; from 7.0 before 7.2.11; from 7.4.0 before 7.4.6; from 8.0.0 before 8.0.4; from 8.2.0 before 8.2.2 — fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
How to fix
Upgrade to a fixed version: valkey-io valkey 7.2.11, 8.0.6, 8.1.4; Redis 6.2.20, 7.2.11, 7.4.6, 8.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/d5728cb5795c966c5b5b1e0f0ac576a7e69af539
- https://github.com/redis/redis/releases/tag/8.2.2
- https://github.com/redis/redis/security/advisories/GHSA-4789-qfc9-5f9q
- http://www.openwall.com/lists/oss-security/2025/10/07/2
- https://github.com/lastvocher/redis-CVE-2025-49844
Get alerted when CVE-2025-49844 or the next vulnerability affects your stack