What’s Vulnerable › Vulnerabilities
CVE-2025-49851: Improper Authentication in ControlID iDSecure On-premises
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-24 · updated 2026-06-17
- Weakness: CWE-287
Description
ControlID iDSecure On-premises versions 4.7.48.0 and prior are vulnerable to an improper authentication vulnerability which could allow an attacker to bypass authentication and gain permissions in the product.
Affected products
- ControlID iDSecure On-premises: before 4.7.50.0 — fixed in 4.7.50.0
How to fix
Upgrade to a fixed version: ControlID iDSecure On-premises 4.7.50.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-49851 or the next vulnerability affects your stack