What’s Vulnerable › Vulnerabilities
CVE-2025-5015: Parsons AccuWeather Widget Cross-site Scripting
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting vulnerability exists in the AccuWeather and Custom RSS widget that allows an unauthenticated user to replace the RSS feed URL with a malicious one.
Affected products
- Parsons AclaraONE Utility Portal: before 1.22 — fixed in 1.22
- Parsons Utility Enterprise Data Management: from 4.02 through 4.26; 5.18, 5.03, 3.30
How to fix
Upgrade to a fixed version: Parsons AclaraONE Utility Portal 1.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5015 or the next vulnerability affects your stack