What’s Vulnerable › Vulnerabilities
CVE-2025-50151: Apache Jena: Configuration files uploaded by administrative users are not check properly
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-20
Description
File access paths in configuration files uploaded by users with administrator access are not validated. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
Affected products
- Apache Software Foundation Apache Jena: before 5.5.0 — fixed in 5.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Jena 5.5.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/12gks5z40gh9bszn1xk8mz34gz586xss
- http://www.openwall.com/lists/oss-security/2025/07/21/2
Get alerted when CVE-2025-50151 or the next vulnerability affects your stack