What’s Vulnerable › Vulnerabilities
CVE-2025-50188: Error-based SQL Injection in Chamilo LMS
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-02 · updated 2026-06-17
- Weakness: CWE-89
Description
Chamilo is a learning management system. Prior to version 1.11.30, the application performs insufficient validation of data coming from the user from the GET value parameter with the following scripts: /plugin/vchamilo/views/syncparams.php and /plugin/vchamilo/ajax/service.php, which allows an attacker to perform an attack aimed at modifying the database query logic by injecting an arbitrary SQL statements. This issue has been patched in version 1.11.30.
Affected products
- chamilo-lms: before 1.11.30 — fixed in 1.11.30
How to fix
Upgrade to a fixed version: chamilo-lms 1.11.30. Check the vendor advisory for mitigations.
References
- https://github.com/chamilo/chamilo-lms/commit/ef54cc0906a3caaa3e7ac9b640b044f03b1fe733
- https://github.com/chamilo/chamilo-lms/releases/tag/v1.11.30
- https://github.com/chamilo/chamilo-lms/security/advisories/GHSA-96j3-x45m-9q3r
Get alerted when CVE-2025-50188 or the next vulnerability affects your stack