What’s Vulnerable › Vulnerabilities
CVE-2025-5035: Firelight Lightbox < 2.3.16 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Firelight Lightbox WordPress plugin before 2.3.16 does not sanitise and escape title attributes before outputting them in the page, which could allow users with a role as low as contributors to perform stored Cross-Site Scripting attacks.
Affected products
- Firelight Lightbox: before 2.3.16 — fixed in 2.3.16
How to fix
Upgrade to a fixed version: Firelight Lightbox 2.3.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5dca30af-4624-4a71-93be-00fa8dc00c97/
- https://wpscan.com/vulnerability/5dca30af-4624-4a71-93be-00fa8dc00c97/
Get alerted when CVE-2025-5035 or the next vulnerability affects your stack