What’s Vulnerable › Vulnerabilities
CVE-2025-50460
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-01 · updated 2026-06-17
- Weakness: CWE-502
Description
A remote code execution (RCE) vulnerability exists in the ms-swift project version 3.3.0 due to unsafe deserialization in tests/run.py using yaml.load() from the PyYAML library (versions = 5.3.1). If an attacker can control the content of the YAML configuration file passed to the --run_config parameter, arbitrary code can be executed during deserialization. This can lead to full system compromise. The vulnerability is triggered when a malicious YAML file is loaded, allowing the execution of arbitrary Python commands such as os.system(). It is recommended to upgrade PyYAML to version 5.4 or higher, and to use yaml.safe_load() to mitigate the issue.
References
- https://github.com/Anchor0221/CVE-2025-50460
- https://github.com/advisories/GHSA-6757-jp84-gxfx
- https://github.com/modelscope/ms-swift
- https://github.com/modelscope/ms-swift/blob/main/tests/run.py#L420
- https://github.com/Anchor0221/CVE-2025-50460
Get alerted when CVE-2025-50460 or the next vulnerability affects your stack