What’s Vulnerable › Vulnerabilities

CVE-2025-5062: WooCommerce <= 9.4.2 - PostMessage-Based Cross-Site Scripting

Description

The WooCommerce plugin for WordPress is vulnerable to PostMessage-Based Cross-Site Scripting via the 'customize-store' page in all versions up to, and including, 9.4.2 due to insufficient input sanitization and output escaping on PostMessage data. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

Affected products

How to fix

Upgrade to a fixed version: Automattic WooCommerce 9.3.4, 9.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-5062 or the next vulnerability affects your stack