What’s Vulnerable › Vulnerabilities
CVE-2025-5071: AI Engine 2.8.0 - 2.8.3 - Authenticated (Subscriber+) Insufficient Authorization to Privilege Escalation via MCP
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-19 · updated 2026-06-17
- Weakness: CWE-863
Description
The AI Engine plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability check on the 'Meow_MWAI_Labs_MCP::can_access_mcp' function in versions 2.8.0 to 2.8.3. This makes it possible for authenticated attackers, with subscriber-level access and above, to have full access to the MCP and run various commands like 'wp_create_user', 'wp_update_user' and 'wp_update_option', which can be used for privilege escalation, and 'wp_update_post', 'wp_delete_post', 'wp_update_comment' and 'wp_delete_comment', which can be used to edit and delete posts and comments.
Affected products
- AI Engine: from 2.8.0 before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: AI Engine 2.8.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ai-engine/tags/2.8.1/labs/mcp.php#L43
- https://plugins.trac.wordpress.org/changeset/3313554/ai-engine#file21
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0e7654a1-0020-4bf1-86be-bdb238a9fe0d?source=cve
Get alerted when CVE-2025-5071 or the next vulnerability affects your stack