What’s Vulnerable › Vulnerabilities
CVE-2025-5096: TablePress <= 3.1.2 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Multiple Parameters
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The TablePress plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the 'data-caption', 'data-s-content-padding', 'data-s-title', and 'data-footer' data-attributes in all versions up to, and including, 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- tobiasbg TablePress – Tables in WordPress made easy: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: tobiasbg TablePress – Tables in WordPress made easy 3.1.3. Check the vendor advisory for mitigations.
References
- https://datatables.net/
- https://github.com/DataTables/DataTablesSrc/blob/29539c40504365bc4be0599e4b0739cf270a2e09/js/core/core.constructor.js#L329
- https://github.com/DataTables/DataTablesSrc/commit/d278ed307035cb8740d2fad86b7cbb995380f7bb
- https://github.com/DataTables/DataTablesSrc/commit/d558328106bef2d48dfc4cf78581dd106f5c1077
- https://plugins.trac.wordpress.org/browser/tablepress/tags/3.1.2/js/jquery.datatables.min.js
- https://plugins.trac.wordpress.org/changeset/3298453/tablepress
- https://tablepress.org/release-announcement-tablepress-3-1-3/
- https://wordpress.org/plugins/tablepress/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cd2dfa02-0404-4300-a5ed-6326f9df6d30?source=cve
Get alerted when CVE-2025-5096 or the next vulnerability affects your stack