What’s Vulnerable › Vulnerabilities
CVE-2025-50989
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-27 · updated 2026-06-17
- Weakness: CWE-78
Description
OPNsense before 25.1.8 contains an authenticated command injection vulnerability in its Bridge Interface Edit endpoint (interfaces_bridge_edit.php). The span POST parameter is concatenated into a system-level command without proper sanitization or escaping, allowing an administrator to inject arbitrary shell operators and payloads. Successful exploitation results in remote code execution with the privileges of the web service (typically root), potentially leading to full system compromise or lateral movement. This vulnerability arises from inadequate input validation and improper handling of user-supplied data in backend command invocations.
Affected products
- OPNsense: before 25.1.8 — fixed in 25.1.8
How to fix
Upgrade to a fixed version: OPNsense 25.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/4rdr/proofs/blob/main/info/OPNsense-25.1-Command-Injection-via-span-parameter.md
- https://github.com/opnsense/changelog/blob/640e96ed6a783254283aead0d0b744fc9143ce6d/community/25.1/25.1.8#L34
Get alerted when CVE-2025-50989 or the next vulnerability affects your stack