What’s Vulnerable › Vulnerabilities
CVE-2025-5101: Improper Control of Generation of Code ('Code Injection') in GitLab
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-27 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue has been discovered in GitLab CE/EE affecting all versions before 18.1.5, 18.2 before 18.2.5, and 18.3 before 18.3.1 that under certain conditions could have allowed an authenticated attacker to distribute malicious code that appears harmless in the web interface by taking advantage of ambiguity between branches and tags during repository imports.
Affected products
- GitLab: before 18.1.5; from 18.2.0 before 18.2.5; 18.3.0 — fixed in 18.1.5, 18.2.5
How to fix
Upgrade to a fixed version: GitLab 18.1.5, 18.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5101 or the next vulnerability affects your stack