What’s Vulnerable › Vulnerabilities
CVE-2025-5103: Ultimate Gift Cards for WooCommerce <= 3.1.4 - Authenticated (Administrator+) SQL Injection via wps_wgm_save_post Function
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-03 · updated 2026-06-17
- Weakness: CWE-89
Description
The Ultimate Gift Cards for WooCommerce plugin for WordPress is vulnerable to boolean-based SQL Injection via the 'default_price' and 'product_id' parameters in all versions up to, and including, 3.1.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- wpswings Ultimate Gift Cards for WooCommerce: before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: wpswings Ultimate Gift Cards for WooCommerce 3.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woo-gift-cards-lite/tags/3.1.4/admin/class-woocommerce-gift-cards-lite-admin.php#L571
- https://plugins.trac.wordpress.org/changeset/3303359/
- https://wordpress.org/plugins/woo-gift-cards-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e9e89383-a9c6-4300-970c-0b36e4d97e3d?source=cve
Get alerted when CVE-2025-5103 or the next vulnerability affects your stack