What’s Vulnerable › Vulnerabilities
CVE-2025-5125: Custom Post Carousels with Owl < 1.4.12 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Custom Post Carousels with Owl WordPress plugin before 1.4.12 uses the featherlight library and makes use of the data-featherlight attribute without sanitizing before using it.
Affected products
- Howard Ehrenberg Custom Post Carousels with Owl: before 1.4.12 — fixed in 1.4.12
How to fix
Upgrade to a fixed version: Howard Ehrenberg Custom Post Carousels with Owl 1.4.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aaf9e3f8-b312-432d-a635-6fe89ff8d13f/
- https://wpscan.com/vulnerability/aaf9e3f8-b312-432d-a635-6fe89ff8d13f/
Get alerted when CVE-2025-5125 or the next vulnerability affects your stack