What’s Vulnerable › Vulnerabilities
CVE-2025-51308
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-06 · updated 2026-06-17
- Weakness: CWE-862
Description
In Gatling Enterprise versions below 1.25.0, a low-privileged user that does not hold the role "admin" could perform a REST API call on read-only endpoints, allowing him to collect some information, due to missing authorization checks.
Affected products
- Gatling: before 1.25.0 — fixed in 1.25.0
How to fix
Upgrade to a fixed version: Gatling 1.25.0. Check the vendor advisory for mitigations.
References
- https://gatling.io/products
- https://github.com/Flo354/vulnerabilities/blob/main/gatling-enterprise/CVE-2025-51308-broken-access-control.md
- https://github.com/Flo354/vulnerabilities/tree/main/gatling-enterprise
Get alerted when CVE-2025-51308 or the next vulnerability affects your stack