What’s Vulnerable › Vulnerabilities
CVE-2025-5142: Simple Page Access Restriction <= 1.0.31 - Cross-Site Request Forgery via Multiple Parameters
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-352
Description
The Simple Page Access Restriction plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.31. This is due to missing nonce validation and capability checks in the settings save handler in the settings.php script. This makes it possible for unauthenticated attackers to (1) enable or disable access protection on all post types or taxonomies, (2) force every new page/post to be public or private, regardless of meta-box settings, (3) cause a silent wipe of all plugin data when it’s later removed, or (4) to conduct URL redirection attacks via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- pluginsandsnippets Simple Page Access Restriction: before 1.0.32 — fixed in 1.0.32
How to fix
Upgrade to a fixed version: pluginsandsnippets Simple Page Access Restriction 1.0.32. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/simple-page-access-restriction/tags/1.0.31/includes/admin/settings/settings.php#L16
- https://plugins.trac.wordpress.org/changeset/3300680/
- https://wordpress.org/plugins/simple-page-access-restriction/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/657e2a4d-7e10-495d-8352-1adc0cb89e83?source=cve
Get alerted when CVE-2025-5142 or the next vulnerability affects your stack