What’s Vulnerable › Vulnerabilities
CVE-2025-5143: TableOn – WordPress Posts Table Filterable <= 1.0.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via tableon_popup_iframe_button Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The TableOn – WordPress Posts Table Filterable plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's tableon_popup_iframe_button shortcode in all versions up to, and including, 1.0.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- realmag777 TableOn – WordPress Posts Table Filterable: before 1.0.4.2 — fixed in 1.0.4.2
How to fix
Upgrade to a fixed version: realmag777 TableOn – WordPress Posts Table Filterable 1.0.4.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/posts-table-filterable/trunk/index.php#L1630
- https://plugins.trac.wordpress.org/changeset/3315337/
- https://wordpress.org/plugins/posts-table-filterable/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/447d3aa6-2ed3-4da3-b9e8-fc7792c8c29a?source=cve
Get alerted when CVE-2025-5143 or the next vulnerability affects your stack