What’s Vulnerable › Vulnerabilities
CVE-2025-51488
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.4, allowing remote attackers to store and execute arbitrary JavaScript by including a malicious HTML payload in the Name parameter when creating a new Admin.
Affected products
- Moonshine: before 3.12.5 — fixed in 3.12.5
How to fix
Upgrade to a fixed version: Moonshine 3.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/GiacoLenzo2109/MoonShine_Software_PoCs
- https://github.com/moonshine-software/moonshine
Get alerted when CVE-2025-51488 or the next vulnerability affects your stack