What’s Vulnerable › Vulnerabilities
CVE-2025-51510
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-19 · updated 2026-06-17
- Weakness: CWE-89
Description
MoonShine was discovered to contain a SQL injection vulnerability under the Blog -> Categories page when using the moonshine-tree-resource (version < 2.0.2) component.
Affected products
- Getmoonshine Moonshine: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: Getmoonshine Moonshine 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/GiacoLenzo2109/MoonShine_Software_PoCs
- https://github.com/lee-to/moonshine-tree-resource
- https://github.com/moonshine-software/moonshine
Get alerted when CVE-2025-51510 or the next vulnerability affects your stack