What’s Vulnerable › Vulnerabilities
CVE-2025-5174: erdogant pypickle pypickle.py load deserialization
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-26 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
Affected products
- erdogant pypickle: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: erdogant pypickle 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/erdogant/pypickle/commit/14b4cae704a0bb4eb6723e238f25382d847a1917
- https://github.com/erdogant/pypickle/issues/2
- https://github.com/erdogant/pypickle/issues/2#issuecomment-2889146579
- https://github.com/erdogant/pypickle/releases/tag/2.0.0
- https://vuldb.com/?ctiid.310262
- https://vuldb.com/?id.310262
- https://vuldb.com/?submit.579157
- https://github.com/erdogant/pypickle/issues/2
Get alerted when CVE-2025-5174 or the next vulnerability affects your stack