What’s Vulnerable › Vulnerabilities
CVE-2025-5175: erdogant pypickle pypickle.py save improper authorization
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-26 · updated 2026-06-17
- Weakness: CWE-266
Description
A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
Affected products
- erdogant pypickle: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: erdogant pypickle 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/erdogant/pypickle/commit/14b4cae704a0bb4eb6723e238f25382d847a1917
- https://github.com/erdogant/pypickle/issues/3
- https://github.com/erdogant/pypickle/issues/3#issue-3070689116
- https://github.com/erdogant/pypickle/issues/3#issuecomment-2888589652
- https://github.com/erdogant/pypickle/releases/tag/2.0.0
- https://vuldb.com/?ctiid.310263
- https://vuldb.com/?id.310263
- https://vuldb.com/?submit.579824
- https://github.com/erdogant/pypickle/issues/3
Get alerted when CVE-2025-5175 or the next vulnerability affects your stack