What’s Vulnerable › Vulnerabilities
CVE-2025-5194: WP Map Block by aBlocks < 2.0.3 - Contributor+ Stored XSS via Marker
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Map Block WordPress plugin before 2.0.3 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- WP Map Block: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: WP Map Block 2.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f90b7ad6-e2a2-4833-a390-a78c64dc2382/
- https://wpscan.com/vulnerability/f90b7ad6-e2a2-4833-a390-a78c64dc2382/
Get alerted when CVE-2025-5194 or the next vulnerability affects your stack