What’s Vulnerable › Vulnerabilities
CVE-2025-5199: LPE on Multipass for macOS
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-12 · updated 2026-06-17
- Weakness: CWE-276
Description
In Canonical Multipass up to and including version 1.15.1 on macOS, incorrect default permissions allow a local attacker to escalate privileges by modifying files executed with administrative privileges by a Launch Daemon during system startup.
Affected products
- Canonical Multipass: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: Canonical Multipass 1.16.0. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/multipass/pull/4115
- https://github.com/canonical/multipass/security/advisories/GHSA-2j82-p5cq-62p3
- https://github.com/canonical/multipass/security/advisories/GHSA-2j82-p5cq-62p3
Get alerted when CVE-2025-5199 or the next vulnerability affects your stack