What’s Vulnerable › Vulnerabilities
CVE-2025-52136
- Severity: low (CVSS 3.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-10 · updated 2026-06-17
- Weakness: CWE-754
Description
In EMQX before 5.8.6, administrators can install arbitrary novel plugins via the Dashboard web interface. NOTE: the Supplier's position is that this is the intended behavior; however, 5.8.6 adds a defense-in-depth feature in which a plugin's acceptability (for later Dashboard installation) is set by the "emqx ctl plugins allow" CLI command.
Affected products
- EMQX: before 5.8.6 — fixed in 5.8.6
How to fix
Upgrade to a fixed version: EMQX 5.8.6. Check the vendor advisory for mitigations.
References
- https://docs.emqx.com/en/emqx/latest/dashboard/introduction.html
- https://docs.emqx.com/en/emqx/latest/deploy/install-docker.html
- https://github.com/ricardojoserf/emqx-RCE
- https://github.com/ricardojoserf/emqx-RCE
Get alerted when CVE-2025-52136 or the next vulnerability affects your stack