What’s Vulnerable › Vulnerabilities
CVE-2025-52435: Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-5
Description
J2EE Misconfiguration: Data Transmission Without Encryption vulnerability in Apache NimBLE. Improper handling of Pause Encryption procedure on Link Layer results in a previously encrypted connection being left in un-encrypted state allowing an eavesdropper to observe the remainder of the exchange. This issue affects Apache NimBLE: through <= 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/164f1c23c18a290908df76ed83fe848bfe4a4903
- https://github.com/apache/mynewt-nimble/commit/ec3d75e909fa6dcadf1836fefc4432794a673d18
- https://lists.apache.org/thread/ow8dzpsqfh9llfclh5fzh6z237brzc0s
- http://www.openwall.com/lists/oss-security/2026/01/08/1
Get alerted when CVE-2025-52435 or the next vulnerability affects your stack