What’s Vulnerable › Vulnerabilities
CVE-2025-52451
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Salesforce Tableau Server on Windows, Linux (tabdoc api - create-data-source-from-file-upload modules) allows Absolute Path Traversal.This issue affects Tableau Server: before 2025.1.3, before 2024.2.12, before 2023.3.19.
Affected products
- Salesforce Tableau Server: before 2023.3.19; from 2024.2 before 2024.2.12; from 2025.1 before 2025.1.3 — fixed in 2023.3.19, 2024.2.12, 2025.1.3
How to fix
Upgrade to a fixed version: Salesforce Tableau Server 2023.3.19, 2024.2.12, 2025.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-52451 or the next vulnerability affects your stack