What’s Vulnerable › Vulnerabilities
CVE-2025-52470: Chamilo: Stored Cross-Site Scripting (XSS) via Session Category Name
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Chamilo is a learning management system. Prior to version 1.11.30, a stored cross-site scripting (XSS) vulnerability exists in the session_category_add.php script. The vulnerability is caused by improper sanitization of the Category Name field, allowing privileged users to inject persistent JavaScript payloads. The injected script is later executed when accessing add_many_sessions_to_category.php, potentially compromising administrative sessions. This issue has been patched in version 1.11.30.
Affected products
- chamilo-lms: before 1.11.30 — fixed in 1.11.30
How to fix
Upgrade to a fixed version: chamilo-lms 1.11.30. Check the vendor advisory for mitigations.
References
- https://github.com/chamilo/chamilo-lms/commit/ead79db4eb034b8c11a3d6036759d083de37530c
- https://github.com/chamilo/chamilo-lms/releases/tag/v1.11.30
- https://github.com/chamilo/chamilo-lms/security/advisories/GHSA-p4m6-gwhg-x89f
Get alerted when CVE-2025-52470 or the next vulnerability affects your stack