What’s Vulnerable › Vulnerabilities
CVE-2025-52497
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-06-17
- Weakness: CWE-193
Description
Mbed TLS before 3.6.4 has a PEM parsing one-byte heap-based buffer underflow, in mbedtls_pem_read_buffer and two mbedtls_pk_parse functions, via untrusted PEM input.
Affected products
- mbedtls: before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: mbedtls 3.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/Mbed-TLS/mbedtls-docs/blob/main/security-advisories/mbedtls-security-advisory-2025-06-2.md
- https://lists.debian.org/debian-lts-announce/2025/08/msg00013.html
Get alerted when CVE-2025-52497 or the next vulnerability affects your stack