What’s Vulnerable › Vulnerabilities

CVE-2025-52520: Apache Tomcat: DoS via integer overflow in multipart file upload

Description

For some unlikely configurations of multipart upload, an Integer Overflow vulnerability in Apache Tomcat could lead to a DoS via bypassing of size limits. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.43, 11.0.9, 9.0.107. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-52520 or the next vulnerability affects your stack