What’s Vulnerable › Vulnerabilities
CVE-2025-52552: FastGPT LastRoute Parameter on Login Page Vulnerable to Open Redirect and DOM-based XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
FastGPT is an AI Agent building platform. Prior to version 4.9.12, the LastRoute Parameter on login page is vulnerable to open redirect and DOM-based XSS. Improper validation and lack of sanitization of this parameter allows attackers execute malicious JavaScript or redirect them to attacker-controlled sites. This issue has been patched in version 4.9.12.
Affected products
- labring FastGPT: before 4.9.12 — fixed in 4.9.12
How to fix
Upgrade to a fixed version: labring FastGPT 4.9.12. Check the vendor advisory for mitigations.
References
- https://github.com/labring/FastGPT/commit/095b75ee27746004106eddeaa4840688a61ff6eb
- https://github.com/labring/FastGPT/security/advisories/GHSA-r976-rfrv-q24m
Get alerted when CVE-2025-52552 or the next vulnerability affects your stack