What’s Vulnerable › Vulnerabilities
CVE-2025-52562: Convey Panel Directory Traversal in LocaleController leading to Remote Code Execution
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-23 · updated 2026-06-17
- Weakness: CWE-22
Description
Convoy is a KVM server management panel for hosting businesses. In versions 3.9.0-rc3 to before 4.4.1, there is a directory traversal vulnerability in the LocaleController component of Performave Convoy. An unauthenticated remote attacker can exploit this vulnerability by sending a specially crafted HTTP request with malicious locale and namespace parameters. This allows the attacker to include and execute arbitrary PHP files on the server. This issue has been patched in version 4.4.1. A temporary workaround involves implementing strict Web Application Firewall (WAF) rules to incoming requests targeting the vulnerable endpoints.
Affected products
- ConvoyPanel panel: from 3.9.0-rc.3, < 4.4.1
References
- https://github.com/ConvoyPanel/panel/commit/f8d6202f3e4912b65dbd9f80ba625576944ab36c
- https://github.com/ConvoyPanel/panel/security/advisories/GHSA-43g3-qpwq-hfgg
Get alerted when CVE-2025-52562 or the next vulnerability affects your stack