What’s Vulnerable › Vulnerabilities
CVE-2025-52568: NeKernal Multiple Memory Corruption Vulnerabilities in mkfs.hefs
- Severity: high (CVSS 8.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-24 · updated 2026-06-17
- Weakness: CWE-20
Description
NeKernal is a free and open-source operating system stack. Prior to version 0.0.3, there are several memory safety issues that can lead to memory corruption, disk image corruption, denial of service, and potential code execution. These issues stem from unchecked memory operations, unsafe typecasting, and improper input validation. This issue has been patched in version 0.0.3.
Affected products
- nekernel-org nekernel: before 0.0.3
References
- https://github.com/nekernel-org/nekernel/commit/6506875ad0ab210b82a5c4ce227bf851508de17d
- https://github.com/nekernel-org/nekernel/commit/6511afbf405c31513bc88ab06bca58218610a994
- https://github.com/nekernel-org/nekernel/pull/35
- https://github.com/nekernel-org/nekernel/pull/36
- https://github.com/nekernel-org/nekernel/security/advisories/GHSA-cmp2-5f6g-mw34
Get alerted when CVE-2025-52568 or the next vulnerability affects your stack