What’s Vulnerable › Vulnerabilities
CVE-2025-52570: Letmein connection limiter allows an arbitrary amount of simultaneous connections
- Severity: low (CVSS 1.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-24 · updated 2026-06-17
- Weakness: CWE-770
Description
Letmein is an authenticating port knocker. Prior to version 10.2.1, The connection limiter is implemented incorrectly. It allows an arbitrary amount of simultaneously incoming connections (TCP, UDP and Unix socket) for the services letmeind and letmeinfwd. Therefore, the command line option num-connections is not effective and does not limit the number of simultaneously incoming connections. This issue has been patched in version 10.2.1.
Affected products
- mbuesch letmein: before 10.2.1
References
- https://github.com/mbuesch/letmein/commit/43207cd77580410d97165d1e3c07361ba6f3558c
- https://github.com/mbuesch/letmein/security/advisories/GHSA-jpv7-p47h-f43j
Get alerted when CVE-2025-52570 or the next vulnerability affects your stack