What’s Vulnerable › Vulnerabilities
CVE-2025-52575: EspoCRM vulnerable to LDAP Injection through Improper Neutralization of Special Elements
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-90
Description
EspoCRM is an Open Source CRM (Customer Relationship Management) software. EspoCRM versions 9.1.6 and earlier are vulnerable to blind LDAP Injection when LDAP authentication is enabled. A remote, unauthenticated attacker can manipulate LDAP queries by injecting crafted input containing wildcard characters (e.g., *). This may allow the attacker to bypass authentication controls, enumerate valid usernames, or retrieve sensitive directory information depending on the LDAP server configuration. This was fixed in version 9.1.7.
Affected products
- espocrm: before 9.1.7 — fixed in 9.1.7
How to fix
Upgrade to a fixed version: espocrm 9.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/espocrm/espocrm/commit/8649f1ac0ce714b2c31727bca3dd95d06e17337f
- https://github.com/espocrm/espocrm/security/advisories/GHSA-rjm8-77fr-4f3v
Get alerted when CVE-2025-52575 or the next vulnerability affects your stack