What’s Vulnerable › Vulnerabilities
CVE-2025-52577: Advantech iView SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability exists in Advantech iView that could allow SQL injection and remote code execution through NetworkServlet.archiveTrapRange(). This issue requires an authenticated attacker with at least user-level privileges. Certain input parameters are not properly sanitized, allowing an attacker to perform SQL injection and potentially execute code in the context of the 'nt authority\local service' account.
Affected products
- Advantech iView: before 5.7.05.7057 — fixed in 5.7.05.7057
How to fix
Upgrade to a fixed version: Advantech iView 5.7.05.7057. Check the vendor advisory for mitigations.
References
- https://www.advantech.com/en/support/details/firmware-?id=1-HIPU-183
- https://www.cisa.gov/news-events/ics-advisories/icsa-25-191-08
Get alerted when CVE-2025-52577 or the next vulnerability affects your stack