What’s Vulnerable › Vulnerabilities
CVE-2025-52694: Execution of arbitrary SQL commands
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 39.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-12 · updated 2026-06-17
- Weakness: CWE-89
Description
Successful exploitation of the SQL injection vulnerability could allow an unauthenticated remote attacker to execute arbitrary SQL commands on the vulnerable service when it is exposed to the Internet, potentially affecting data confidentiality, integrity, and availability. Users and administrators of affected product versions are advised to update to the latest versions immediately.
Affected products
- Advantech IoT Edge Linux docker: before 2.0.2 — fixed in 2.0.2
- Advantech IoT Edge Windows: before 2.0.2 — fixed in 2.0.2
- Advantech IoTSuite Growth Linux docker: before 2.0.2 — fixed in 2.0.2
- Advantech Iotsuite Saas Composer: before 3.4.15 — fixed in 3.4.15
- Advantech IoTSuite Starter Linux docker: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: Advantech IoT Edge Linux docker 2.0.2; Advantech IoT Edge Windows 2.0.2; Advantech IoTSuite Growth Linux docker 2.0.2; Advantech Iotsuite Saas Composer 3.4.15; Advantech IoTSuite Starter Linux docker 2.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-52694 or the next vulnerability affects your stack