What’s Vulnerable › Vulnerabilities
CVE-2025-5277
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-28 · updated 2026-06-17
- Weakness: CWE-78
Description
aws-mcp-server MCP server is vulnerable to command injection. An attacker can craft a prompt that once accessed by the MCP client will run arbitrary commands on the host system.
Affected products
- alexei-led aws-mcp-server: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: alexei-led aws-mcp-server 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/alexei-led/aws-mcp-server/blob/94d20ae1798a43ac7e3a28e71900d774e5159c8a/src/aws_mcp_server/cli_executor.py#L92
- https://github.com/alexei-led/aws-mcp-server/commit/94d20ae1798a43ac7e3a28e71900d774e5159c8a
Get alerted when CVE-2025-5277 or the next vulnerability affects your stack