What’s Vulnerable › Vulnerabilities
CVE-2025-52856: VioStor
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-287
Description
An improper authentication vulnerability has been reported to affect VioStor. If a remote attacker, they can then exploit the vulnerability to compromise the security of the system. We have already fixed the vulnerability in the following version: VioStor 5.1.6 build 20250621 and later
Affected products
- QNAP Systems Inc. QVR: from 5.1.0 before 5.1.6; 5.1.6 — fixed in 5.1.6
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QVR 5.1.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-52856 or the next vulnerability affects your stack