What’s Vulnerable › Vulnerabilities
CVE-2025-52886: Poppler Use After Free Vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-02 · updated 2026-06-17
- Weakness: CWE-416
Description
Poppler is a PDF rendering library. Versions prior to 25.06.0 use `std::atomic_int` for reference counting. Because `std::atomic_int` is only 32 bits, it is possible to overflow the reference count and trigger a use-after-free. Version 25.06.0 patches the issue.
Affected products
- poppler: before 25.06.0 — fixed in 25.06.0
How to fix
Upgrade to a fixed version: poppler 25.06.0. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/poppler/poppler/-/commit/04bd91684ed41d67ae0f10cde0660e4ed74ac203
- https://gitlab.freedesktop.org/poppler/poppler/-/commit/ac36affcc8486de38e8905a8d6547a3464ff46e5
- https://gitlab.freedesktop.org/poppler/poppler/-/issues/1581
- https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/1828
- https://securitylab.github.com/advisories/GHSL-2025-054_poppler/
- http://www.openwall.com/lists/oss-security/2025/07/11/5
- http://www.openwall.com/lists/oss-security/2025/07/12/1
Get alerted when CVE-2025-52886 or the next vulnerability affects your stack